Ubuntu Fan

life with ubuntu on a thinkpad T40

Archive for August, 2007

Remote X Applications

Posted by ubuntufan on August 17, 2007

I know, I know…I’ve disappeared for a while. Summer is busy for me and I had to…..well I really have no excuse, but I’m back again for at least a while.

As you may or probably do not know, my work environment is composed of 29 glorious, non-windows servers. A fair amount of them are Solaris 9 with a dusting of Solaris 10, with the rest being various Linux distros. I wish I could change them all to the same distro but everything works, so I won’t complain too much. I occasionally wander away from the command line and need to run an X application of some sort; usually an installer. No problem right? From a CLI, just type xhost + , ssh to the Solaris box I need, export the display and that’s it…run any X app you like. Wait…what’s this? Error: Can’t open display: ????

This was making me mad….I had to install Oracle and didn’t feel like having to dig around to find out what the problem was. I brought up my Chatzilla window and logged into #ubuntu ( a great place for answers) The solution was simple and I believe it is a new security “feature” in 7.04 ( but I’m not 100% sure) All you have to do is go to the system menu, click on Administration and then click on Login Window. From there, click on the security tab and un-check the “Deny TCP connections to Xserver” check box….that’s it. Everything will work as expected from there.

There is a chance that this could possibly be a security hole but it’s easy enough to toggle on and off when needed if you’re paranoid. Hope this helps.

Dale

Posted in Administration, Networking, ubuntu, xorg | 16 Comments »